[blag-whereto] running blag from usb key solved

Junichirô junichiro at aktivix.org
Sat Mar 12 18:52:31 UTC 2011

I think it would be fine to put it on the forum, no?

On Sat, 12 Mar 2011 11:53:24 -0600
mark <harrismh777 at charter.net> wrote:

> > I am having trouble cominng up with the right combination of root= and
> > rootfstype=  settings   also  boot=   
> > 
> > So, any help would be appreciated.  I am slightly embarrassed because I
> > have be able to put my gNewSense on a usb key and run there, and I
> > thought I knew something about the boot process... but apparently, I was
> > wrong.   :}
> Well, I solved this little dilemma; thought it might help someone
> else... 
> The Fedora usb disk creation utility is broken somehow (I have not had
> the time to figure out why) but it creates the syslinux.cfg file
> incorrectly... [ root=live:UUID=AE34-5623 ]   is not correct because the
> UUID for the usb is wrong. I feel a little silly, but it took me a while
> to discover this. The utility is assuming a UUID from some other drive,
> but not the usb key it is actually installing to. Changing this line to
> read either of the following ways works to get the boot=up to find the
> root partition:
> root=live:LABEL=FEDORA
> root=live:UUID=xxxx-xxxx   <===xxxx-xxxx is the "real" UUID of the usb
> The bad UUIDs end up in olpc.fth as well. 
> Well, alls well that ends well, my BLAG is booting up fine from the usb
> key and I am happy as a clam. 
> Cheers hackers!
> -- 
> Kind regards,
> M Harris
> _______________________________________________
> blag-whereto mailing list
> blag-whereto at lists.aktivix.org
> https://lists.aktivix.org/mailman/listinfo/blag-whereto

Junichirô <junichiro at aktivix.org>

More information about the blag-whereto mailing list